Pages

Tuesday, December 18, 2012

Configuration and Settings Cisco VoIP Tie Line

This article explains how to configure VoIP on Cisco router and composed of the following sections related to VOIP. I have shown following scenarios, configuration, diagrams (and Visio stencile) to make you understand and adapt it to your work.

Cisco IP Tie Line, Tie Trunk
The Cisco + PBX diagram illustrates the topology of this connection example.
Below are some of the VoIP traffic scenario;
     1. HQ Office -> any IP Telephony site: Since we are on VoIP, traffic will route to available link. In case there will be an outage on Verizon MPLS all traffic including voice will be routed to Brach Office VPN. This might impact a lot on the voice quality because Internet Link will not guaranteed or priority on VPN.

     2. Branch Office -> HQ Office site VoIP call: In case of link outage between two offices. Voice traffic will reroute to VPN -> MPLS before it reaches the HQ Office PBX. Again no guarantee on voice quality because of the path that it will take.

     3. Branch Office -> IP Telephony via HQ Office PBX routing: Outages on either E1 link between two office or Verizon MPLS will “Greatly” impact the quality of voice. Meaning if Branch Office call IP Telephony voice traffic will go to HQ Office, then HQ Office will route call to Branch Office again since MPLS is down, then route to VPN.

The following example shows  the configuration VoIP for Tie Line connection between 2 site with PABx  
hostname BRCM1-3845 hostname HQRV1-7206VXR
isdn switch-type primary-qsig
voice-card 1
no dspfarm
!
controller E1 1/1
pri-group timeslots 1-17
description --- QSIG Trunk to Nortel PBX ---
card type e1 2
!
isdn switch-type primary-net5
voice-card 0
no dspfarm
!
controller E1 0/2/0
pri-group timeslots 1-17
description --- Inbound E1 interface ---
!
controller E1 0/2/1
pri-group timeslots 1-17
description --- Outbound E1 interface ---
!
controller E1 2/0
pri-group timeslots 1-31
description ISDN/PRI E1 - TelecomAsia
vlan internal allocation policy ascending
interface Loopback0
description Loopback for BRCM1-3845
ip address 176.40.203.248 255.255.255.255
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
interface Loopback0
description Hostname:HQRV1-7206VXR
ip address 176.40.203.222 255.255.255.255
no ip redirects
no ip proxy-arp
ip route-cache flow
no ip route-cache cef
no ip mroute-cache
h323-gateway voip interface
h323-gateway voip id SGDCGK1 ipaddr 176.44.1.252 1719
h323-gateway voip h323-id HQRV1-7206VXR
h323-gateway voip tech-prefix 1#
h323-gateway voip bind srcaddr 176.40.203.222
interface FastEthernet0/0
description Connected to LAN
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip pim sparse-dense-mode
no ip route-cache cef
no ip route-cache
no ip mroute-cache
speed 100
full-duplex
interface FastEthernet0/0
description *** OFFICE ETHERNET SEGMENT, THAILAND***
ip address 176.40.200.210 255.255.255.252
no ip proxy-arp
ip pim sparse-dense-mode
no ip route-cache
no ip mroute-cache
ip policy route-map Offshore
duplex full
no mop enabled
interface Serial1/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn incoming-voice voice
no cdp enable
interface Serial0/2/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
interface Serial0/2/1:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
voice-port 1/1:15
cptone TH
voice-port 0/2/0:15
!
voice-port 0/2/1:15
dial-peer cor custom
!
dial-peer voice 1000 pots
destination-pattern 8596[2-5]...
progress_ind setup enable 3
progress_ind alert enable 8
direct-inward-dial
port 1/1:15
forward-digits 7
!
dial-peer voice 10001 voip
destination-pattern 8T
session target ipv4:176.40.203.230
dtmf-relay h245-alphanumeric
ip qos dscp ef signaling
no vad
dial-peer voice 1000 pots
description --- IPT Inbound to Loop ---
preference 1
destination-pattern 8[2-9]......
progress_ind setup enable 3
progress_ind alert enable 8
direct-inward-dial
port 0/2/0:15
forward-digits 7
!
dial-peer voice 2000 pots
description --- IPT Outbound from Loop ---
preference 2
incoming called-number .
direct-inward-dial
port 0/2/1:15
!
dial-peer voice 5127 voip
description --- IPT Peer to HQ via HQRV1 ---
huntstop
preference 3
destination-pattern 512[6-7]...
session target ipv4:176.40.203.222
dtmf-relay h245-alphanumeric
ip qos dscp ef signaling
no vad
!
gateway
timer receive-rtp 1200
Cisco_Icons_Visio
To download the Visio Stencils, sample full configuration go here icons, configuration

1 comments:

Post a Comment